[openstreetmap/openstreetmap-website] vagrant up failing due to permission issue and more (#1888)

Michael Hwang notifications at github.com
Fri Jun 1 15:30:13 UTC 2018


Thanks @tomhughes .  I just tried your changes but I got the following error:

```
==> default: Mounting shared folders...
    default: /srv/openstreetmap-website => /home/mhwang/workspace/labs/mw/3rd-party/openstreetmap-website
Vagrant was unable to mount VirtualBox shared folders. This is usually
because the filesystem "vboxsf" is not available. This filesystem is
made available via the VirtualBox Guest Additions and kernel module.
Please verify that these guest additions are properly installed in the
guest. This is not a bug in Vagrant and is usually caused by a faulty
Vagrant box. For context, the command attempted was:

mount -t vboxsf -o uid=1000,gid=1000 srv_openstreetmap-website /srv/openstreetmap-website

The error output from the command was:
```

I think `generic/ubuntu1604` doesn't have the virtualbox guest additions installed which is needed to share a directory on the host to the guest.  Replacing `generic/ubuntu1604` with `ubuntu/xenial64` worked.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/openstreetmap/openstreetmap-website/issues/1888#issuecomment-393916807
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.org/pipermail/rails-dev/attachments/20180601/771e38ba/attachment.html>


More information about the rails-dev mailing list