[openstreetmap/openstreetmap-website] Could not open library 'libarchive.so.13': libarchive.so.13: cannot open shared object file: No such file or directory. (#2343)

Andy Allan notifications at github.com
Wed Aug 7 16:07:34 UTC 2019


> Well there is no useful support to give here other than not to use the vagrant method - there is no support we can give which will make it work.

This is simply not true. We can provide support by fixing the obvious problems with the vagrant setup scripts. If one person has reported them broken, I'm sure others have tried and given up without alerting us.

> Now a bug ticket asking for the Vagrantfile to be fixed would be reasonable

You could consider this as such a bug, since it's obvious to you and me what needs to be changed in the vagrant scripts to get it working again. But you just closed the ticket, and I'm glad that I spotted the notification and reopened it since it's an issue where something is broken and needs fixing.

>  it will just get broken again next week

It's not outwith the realms of the possible to deal with this, as I know you know. So please don't declare everything as hopeless. I'm no big fan of the vagrant scripts, but if it helps new developers get started then I'll put in the effort to make it work.

But like I said before, if you don't want to do this stuff that's fine, just please leave the support issues alone for other people to deal with.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/openstreetmap/openstreetmap-website/issues/2343#issuecomment-519164044
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.org/pipermail/rails-dev/attachments/20190807/a84ff0e0/attachment.html>


More information about the rails-dev mailing list