[openstreetmap/openstreetmap-website] Supporting multiple API versions (#2353)

Simon Poole notifications at github.com
Fri Aug 30 11:27:58 UTC 2019


simonpoole commented on this pull request.



> -           <member type='relation' role='some' ref='#{relation.id}'/>
-          </relation>
-         </create>
-        </osmChange>
+      all_api_versions.each do |api_version|
+        user = create(:user)
+        changeset = create(:changeset, :user => user)
+        node = create(:node)
+        way = create(:way_with_nodes, :nodes_count => 2)
+        relation = create(:relation)
+
+        basic_authorization user.email, "test"
+
+        # simple diff to create a node way and relation using placeholders
+        diff = <<CHANGESET.strip_heredoc
+          <osmChange>

As I pointed out above, we return the data model version in all kinds of places, not just in OSC format. That needs to be decoupled from the API version.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/openstreetmap/openstreetmap-website/pull/2353#discussion_r319470752
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.org/pipermail/rails-dev/attachments/20190830/fe3feb9c/attachment.html>


More information about the rails-dev mailing list