[openstreetmap/openstreetmap-website] Remove require_terms_* configuration options (#2136)

Andy Allan notifications at github.com
Wed Feb 6 14:54:45 UTC 2019


Fixes #2097 
You can view, comment on, or merge this pull request online at:

  https://github.com/openstreetmap/openstreetmap-website/pull/2136

-- Commit Summary --

  * Remove the require_terms_seen configuration option
  * Remove require_terms_agreed configuration option

-- File Changes --

    M app/abilities/ability.rb (4)
    M app/abilities/capability.rb (4)
    M app/controllers/amf_controller.rb (10)
    M app/controllers/application_controller.rb (2)
    M app/controllers/users_controller.rb (2)
    M config/example.application.yml (4)
    M test/controllers/changeset_comments_controller_test.rb (80)
    M test/controllers/users_controller_test.rb (10)
    M test/factories/user.rb (1)
    M test/integration/user_terms_seen_test.rb (112)

-- Patch Links --

https://github.com/openstreetmap/openstreetmap-website/pull/2136.patch
https://github.com/openstreetmap/openstreetmap-website/pull/2136.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/openstreetmap/openstreetmap-website/pull/2136
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.org/pipermail/rails-dev/attachments/20190206/79b3f353/attachment.html>


More information about the rails-dev mailing list