[openstreetmap/openstreetmap-website] Fix installation instructions for Mac OS X (#2403)

Matt Amos notifications at github.com
Fri Oct 18 15:32:14 UTC 2019


The installation of `libxml-ruby` was broken because it was picking up the system version of the libxml2 library. By setting a `bundler` config item, it's possible to point it to the right place.

Also updated the instructions for `phantomjs` -- do we even use this anymore? Anyway, Homebrew has moved to a cask and it is now not officially supported, but can be installed. Finally, added some of the extra command line tools that are used (`pngcrush`, `optipng`, etc...)

Hopefully this fixes #2371 - if anyone else has a Mac OS X machine, please test it out and let me know. For reference, I'm running 10.15 (Catalina), so it would be super helpful if anyone with other versions could test the instructions out.

You can view, comment on, or merge this pull request online at:

  https://github.com/openstreetmap/openstreetmap-website/pull/2403

-- Commit Summary --

  * Fix installation instructions for Mac OS X

-- File Changes --

    M INSTALL.md (30)

-- Patch Links --

https://github.com/openstreetmap/openstreetmap-website/pull/2403.patch
https://github.com/openstreetmap/openstreetmap-website/pull/2403.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/openstreetmap/openstreetmap-website/pull/2403
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.org/pipermail/rails-dev/attachments/20191018/3edf42e1/attachment.html>


More information about the rails-dev mailing list