<p>Yes keeping the GPX importer code around is a major pain because it has dependencies like RMagick which are both something of a pain to deal with and also not used by anybody else, plus it may well be entirely broken now as it is never tested.</p>

<p>On top of which there are a whole bunch of translations which it uses, and which are therefore are never used, but which people are busy translating - a whole bunch came up with "lego" complaints about them on TranslateWiki only last week.</p>

<p>Personally I'd just rip out the old ruby importer...</p>

<p>A related issue is the fact that the emails that are sent, by the C importer, are not translatable at all...</p>

<p style="font-size:small;-webkit-text-size-adjust:none;color:#666;">—<br>Reply to this email directly or <a href='https://github.com/openstreetmap/openstreetmap-website/issues/281#issuecomment-17861820'>view it on GitHub</a>.<img src='https://github.com/notifications/beacon/uTRSc6ihLa7Shf84BpiOpiaRQm7QQYFluxj9v87IpgPHSdThFwaw4OiDRKiwFsSi.gif' height='1' width='1'></p>