<p>To summarise, and ignoring all the irrelevant confusion about umlauts, and the various accidental modifications of unrelated bits of the URL in the initial report, the problem is that we generate this link:</p>

<pre><code>http://de.wikipedia.org/wiki/de:Englischer%20Garten%20(M%C3%BCnchen)?uselang=en-GB#Japanisches%20Teehaus
</code></pre>

<p>when we need to generate:</p>

<pre><code>http://de.wikipedia.org/wiki/de:Englischer%20Garten%20(M%C3%BCnchen)?uselang=en-GB#Japanisches_Teehaus
</code></pre>

<p>with an underscore in the anchor component, because mediawiki requires spaces to be translated to underscore for the anchor name when multiple words are used in a section heading.</p>

<p>The question is, is this really a bug in the web site core? or is the data in the database wrong? It seems that <code>de:Englischer Garten (München)#Japanisches Teehaus</code> is not really the right reference and it should be <code>de:Englischer Garten (München)#Japanisches_Teehaus</code>.</p>

<p style="font-size:small;-webkit-text-size-adjust:none;color:#666;">—<br>Reply to this email directly or <a href="https://github.com/openstreetmap/openstreetmap-website/issues/967#issuecomment-101665103">view it on GitHub</a>.<img alt="" height="1" src="https://github.com/notifications/beacon/ABWnLbVKQUWOMp3KVy0qjXdIf01GTaquks5oI0qkgaJpZM4EZJ-Y.gif" width="1" /></p>
<div itemscope itemtype="http://schema.org/EmailMessage">
  <div itemprop="action" itemscope itemtype="http://schema.org/ViewAction">
    <link itemprop="url" href="https://github.com/openstreetmap/openstreetmap-website/issues/967#issuecomment-101665103"></link>
    <meta itemprop="name" content="View Issue"></meta>
  </div>
  <meta itemprop="description" content="View this Issue on GitHub"></meta>
</div>