<p><a href="https://github.com/tomhughes" class="user-mention">@tomhughes</a> Sorry, I don't follow; I haven't mentioned the left side panel opening, the issue is when you close the side panel. If you do my step 1 and immediately close the search box, the map doesn't move. If you do my step 3 as a fresh page load and close the way box, the map does not move. It is only if you start with a search box, click a search result, <em>then</em> close the search box, that the map/URL gets confused, not doing the same thing as starting with step 3 afresh. So that seems like a clear bug to me, having the URL hash ever not matching the centre point of the shown map, and I'm not sure what problems fixing that particular instance would cause; it's certainly the only issue I get frequently using OSM. Sorry if I've misunderstood.</p>

<p style="font-size:small;-webkit-text-size-adjust:none;color:#666;">—<br>Reply to this email directly or <a href="https://github.com/openstreetmap/openstreetmap-website/issues/729#issuecomment-106223712">view it on GitHub</a>.<img alt="" height="1" src="https://github.com/notifications/beacon/ABWnLfvZuFK9HooYccMAlZAGnfKoIp0Iks5oNsOcgaJpZM4BzTx0.gif" width="1" /></p>
<div itemscope itemtype="http://schema.org/EmailMessage">
  <div itemprop="action" itemscope itemtype="http://schema.org/ViewAction">
    <link itemprop="url" href="https://github.com/openstreetmap/openstreetmap-website/issues/729#issuecomment-106223712"></link>
    <meta itemprop="name" content="View Issue"></meta>
  </div>
  <meta itemprop="description" content="View this Issue on GitHub"></meta>
</div>