<p>This is the openstreetmap issue tracker, not the postgres help desk. You need to make sure you have a working postgres server that you can connect to before you start trying to install our code.</p>

<p>If "psql template1" does not work at the command line then you are not ready to install out code and you need to seek help from an appropriate postgresl forum.</p>

<p>I would add that installing postgres from source is almost certainly a mistake. You don't say what platform you are using, but unless it is seriously obscure I would imagine there are far better solutions using a prebuilt version.</p>

<p style="font-size:small;-webkit-text-size-adjust:none;color:#666;">—<br>Reply to this email directly or <a href="https://github.com/openstreetmap/openstreetmap-website/issues/978#issuecomment-106764470">view it on GitHub</a>.<img alt="" height="1" src="https://github.com/notifications/beacon/ABWnLVW6EnMQkY1d2Mblb6HcNjCs61DCks5oODKRgaJpZM4Eu7Zt.gif" width="1" /></p>
<div itemscope itemtype="http://schema.org/EmailMessage">
  <div itemprop="action" itemscope itemtype="http://schema.org/ViewAction">
    <link itemprop="url" href="https://github.com/openstreetmap/openstreetmap-website/issues/978#issuecomment-106764470"></link>
    <meta itemprop="name" content="View Issue"></meta>
  </div>
  <meta itemprop="description" content="View this Issue on GitHub"></meta>
</div>