<div dir="ltr">Hi,<div><br></div><div>I recently installed [openstreetmap-website](<a href="https://github.com/openstreetmap/openstreetmap-website">https://github.com/openstreetmap/openstreetmap-website</a>) and for most part it worked great. I have a few suggestions so that this expereince can be even lesser painful for any new contributor.</div><div><br></div><div><a href="https://github.com/openstreetmap/openstreetmap-website/blob/master/INSTALL.md#minimum-requirements">Minimum requirements</a> mentions that ImageMagick is a requirement however install commands for ubuntu or fedora don't have ImageMagick and ImageMagick-dev(el).</div><div><br></div><a href="https://github.com/openstreetmap/openstreetmap-website/blob/master/INSTALL.md#postgresql-btree-gist-extension">PostgreSQL Btree-gist Extension</a> should have user ( -u <username>) in it.<div><br></div>It might be worth mentioning that <a href="https://github.com/openstreetmap/openstreetmap-website/blob/master/CONFIGURE.md#populating-the-database">Populating the database</a> is not a necessary step. If some reason one wants to do it then probably there should be links directing the contributor where he can get an OSM extract. Currently it is <a href="http://config.md">config.md</a> -> osmosis -> Downloading -> Go Figure!<div>An example link to <span style="color:rgb(51,51,51);font-family:Consolas,'Liberation Mono',Menlo,Courier,monospace;font-size:12px;line-height:16.8px;white-space:pre"><a href="http://download.geofabrik.de/europe/great-britain/england/greater-london-latest.osm.pbf">http://download.geofabrik.de/europe/great-britain/england/greater-london-latest.osm.pbf</a></span></div><div>would be a lot less overwhelming for someone yet to be familiar with the project.</div><div><div><br></div><div>Cheers,</div><div>Aditya</div></div></div>