[Tagging] Bridges redux

Christopher Hoess cahoess at gmail.com
Thu May 9 20:41:39 UTC 2013


I included the types of movable bridge in the "bridge" key in the previous
round of my proposal in January, for similar reasons (compatibility,
brevity). I made the change based on LM_1's comments (<
and reiterated on the wiki).

Specifically, what made me switch was thinking about renderers, routers,
and other consumers of the data. The list of movable bridge types is rather
volatile: it's easy to imagine someone coming up with additional types
besides the ones I've listed for movable bridges. If all the movable bridge
types are filed under "bridge", adding a new type will not work with
downstream consumers until they've been patched (which seems to be a fairly
serious obstacle). Using "bridge=movable" with "bridge:movable" is a little
more wordy, but it allows renderers to render it as a bridge and routers to
recognize that it might open in the middle of the commute, even if it's
some exotic type of movable bridge not provided for here.

577 instances isn't that big an installed base, all things considered (and
they don't even render properly, right now). "movable" vs "moveable" is
annoying, but they shouldn't build up too badly as long as someone is
regularly sweeping taginfo for the misspelling.

I'm not absolutely set either way; since you bring it up, I'd like to hear
other people weigh in as well.


Chris Hoess

On Thu, May 9, 2013 at 10:35 AM, Richard Fairhurst <richard at systemed.net>wrote:

> This is generally good. One comment:
> Christopher Hoess wrote:
> > [...] we might also consider whether "movable"
> > should be under "bridge" or "bridge:type". Placing it in the
> > former would mean patching current renderers (e.g.,
> > Mapnik), but placing it in the latter makes specific movable
> > bridge types (e.g., bascule, swing) rather wordy to tag, with
> > three separate keys.
> It makes more sense to replace:
> bridge=movable; bridge:movable=swing
> bridge=movable; bridge:movable=lift
> bridge=movable; bridge:movable=bascule
> bridge=movable; bridge:movable=drawbridge
> bridge=movable; bridge:movable=transporter
> with simply
> bridge=swing
> bridge=lift
> bridge=bascule
> bridge=drawbridge
> bridge=transporter
> This removes unnecessary duplication, is more memorable ("is it 'moveable'
> or 'movable'...?") and accords with current usage (e.g. 577 occurrences of
> bridge=swing).
> cheers
> Richard
> --
> View this message in context:
> http://gis.19327.n5.nabble.com/Bridges-redux-tp5760227p5760348.html
> Sent from the Tagging mailing list archive at Nabble.com.
> _______________________________________________
> Tagging mailing list
> Tagging at openstreetmap.org
> http://lists.openstreetmap.org/listinfo/tagging
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.org/pipermail/tagging/attachments/20130509/73afd74e/attachment.html>

More information about the Tagging mailing list