[Tagging] layer=-1, rivers, bridges and tunnels

Dave F. davefox at madasafish.com
Tue Apr 22 09:57:29 UTC 2014


On 21/04/2014 21:20, Martin Koppenhoefer wrote:
>
> 2014-04-21 20:48 GMT+02:00 Richard Z. <ricoz.osm at gmail.com 
> <mailto:ricoz.osm at gmail.com>>:
>
>     > Without any additional tags like "tunnel=*" or "covered=*", a
>     > "layer=-1" river shouldn't be rendered differently than a
>     "layer=1" or
>     > even in the absence of any "layer" tag. This is a bug in OsmAnd. You
>
>     except for the the very frequent case when the river with a layer=-1
>     goes through a landuse=* area with a layer=0.
>
>
>
> +1, as soon as there is any other object on a different layer, be it 
> landuse, a place area or something else, with the lower layer tag you 
> are excluding the river from this feature and putting it below.
>

I'm genuinely surprised how a relatively simple tag can cause such 
confusion amongst experienced mappers. The above is an example of 
incorrect tagging & therefore should be fixed. However, on saying that, 
it doesn't mean that it will automatically be rendered as such. As has 
been said many times previously it is just a *guide* for the renderer, 
who, as with Mapnik, will ignore the layer=* tags in that example & let 
common sense prevail.

Dave F.


---
This email is free from viruses and malware because avast! Antivirus protection is active.
http://www.avast.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.org/pipermail/tagging/attachments/20140422/8271d91a/attachment.html>


More information about the Tagging mailing list