[talk-au] ISP caching problems with JOSM ?

Ross Scanlon info at 4x4falcon.com
Thu Sep 12 13:22:50 UTC 2013


Sounds more like the caching within JOSM.

Cheers
Ross


On 12/09/13 23:15, Grant Slater wrote:
> Hi Ian,
>
> The api.openstreetmap.org map data servers send "no-cache" headers and
> proxy/caches should therefore NOT be caching the results...
> But some ISPs are too aggressive with their caching.
>
> Make sure JOSM is set to the default OSM server (there are 3rd party
> caching API servers available):
> JOSM ->  Edit ->  Preferences (shortcut: F12) ->  Connection Settings
> (World Icon) ->  make sure: "User the default OSM server URL" is
> checked.
>
> I am happy to help diagnose the error with you.
>
> Regards
>   Grant
>
> On 12 September 2013 13:01, Steer<isteer at iinet.net.au>  wrote:
>> I’m wondering if I’m striking caching problems with my ISP or my PC.  I make
>> changes and upload them with no error messages and close JOSM.  I re-open
>> the next day, and my changes aren’t there – but they are present in the
>> “slippy map”.  I re-do them and upload them and get a conflict saying the
>> server version is newer than mine.  I can close JOSM, re-open and
>> re-download, and the server version and my version don’t change.
>>
>>
>>
>> I have googled this problem, but it was all a bit above my head.  Does
>> anyone have a solution for this problem they can describe in simple terms ?
>> J
>>
>>
>>
>> thanks
>>
>>
>>
>> Ian
>>
>>
>> _______________________________________________
>> Talk-au mailing list
>> Talk-au at openstreetmap.org
>> https://lists.openstreetmap.org/listinfo/talk-au
>>
>
> _______________________________________________
> Talk-au mailing list
> Talk-au at openstreetmap.org
> https://lists.openstreetmap.org/listinfo/talk-au




More information about the Talk-au mailing list