[Talk-de] Anzeige von Multipolygonen

Sven Rautenberg sven at rtbg.de
Fr Jan 9 12:27:58 UTC 2009


Martin Koppenhoefer schrieb:
> zum Rendering von Multipolygonen habe ich auch ein Beispiel, dass ich in
> Osmarender nicht gerendert bekomme, in Mapnik allerdings schon:
> 
> http://openstreetmap.org/?lat=40.75122&lon=14.49542&zoom=17&layers=B000FTF
> 
> weiss hier jemand Rat?

Mapnik und Osmarender haben noch ein Problem mit verschachtelten
Multipolygonen.

Bei deinem Beispiel hast du Glück, dass Mapnik "korrekt falsch liegt".
Ich habe ein ähnliches Beispiel (See im Wald mit Waldinsel), bei dem
Mapnik falsch und Osmarender korrekt arbeitet.

Die Cyclemap (ein anderer Mapnik) kriegt übrigens beide Beispiele nicht
korrekt hin.

Ach ja, weil es auf dieser Mailingliste immer wieder vergessen wird:
Wenn ihr nur einen Link angebt und die Aussage "Da ist Renderer X
falsch", dann wäre es als wichtige Zusatzinfo notwendig, auch zu sagen,
was ihr denn als Erwartungswert für "richtig" habt, bzw. was genau denn
"falsch" sein soll.

Denn genau betrachtet ist deine Aussage falsch: Du kriegst dein Beispiel
ja sowohl in Mapnik als auch Osmarender als auch Cyclemap gerendert.
Aber was gefällt dir an den einzelnen Ergebnissen nicht? Das sollte
erwähnt werden, ansonsten ist es nämlich ein Ratespielchen, bei dem man
raten muss, was du mit deinem Tagging wohl gemeint haben könntest, und
ob nun das Tagging korrekt (also passend zu deiner Intention) ist und
das Rendering falsch, oder ob das Rendering zum Tagging passt, aber
dieses falsch ist und nicht zu deiner Intention passt. :)

Viele Grüße
Sven




Mehr Informationen über die Mailingliste Talk-de