[Talk-de] Problem mit aktueller Osmosis-Version.

Kai Behncke Kai-Behncke at gmx.de
Di Nov 10 11:10:52 UTC 2009


Hallo Markus,

Erstmal vielen Dank für den Tipp, leider klappt es noch nicht wie es soll.

Ich habe den Pfad zur /lib/test/jpf-1.5.jar in die Batch-Datei eingefügt:

------------
REM MAINCLASS=org.openstreetmap.osmosis.core.Osmosis
REM EXEC="$JAVACMD -cp $MYAPP_HOME/osmosis.jar:$MYAPP_HOME/lib/test/jpf-1.5.jar:osmosis.jar:$MYAPP_HOME/lib/mysql-connector-java-5.0.7-bin.jar:$MYAPP_HOME/lib/postgresql-8.3-603.jdbc4.jar:$MYAPP_HOME/lib/postgis_1.3.2.jar $MAINCLASS $@"
REM 
REM #echo $EXEC
REM exec $EXEC
set MAINCLASS=org.openstreetmap.osmosis.core.Osmosis

SET EXEC=%JAVACMD% %JAVACMD_OPTIONS% -cp %MYAPP_HOME%\osmosis.jar;%MYAPP_HOME\lib\test\jpf-1.5.jar;%MYAPP_HOME%\lib\commons-logging.jar;%MYAPP_HOME%\lib\mysql-connector-java-5.0.7-bin.jar;%MYAPP_HOME%\lib\postgresql-8.3-603.jdbc4.jar;%MYAPP_HOME%\lib\postgis_1.3.2.jar %MAINCLASS% %OSMOSIS_OPTIONS% %*

%EXEC%
-------------

Wenn ich dann ausführe:

E:\osmosis\bin>osmosis --read-xml E:/gis_customizing_09/niedersachsen_osm/niedersachsen.osm --bb left=7.917 right=8.1694
 top=52.3537 bottom=52.217 --write-xml E:/gis_customizing_09/niedersachsen_osm/osnabrueck3.osm

Dann erhalte ich:

Usage: java [-options] class [args...
           (to execute a class)
   or  java [-options] -jar jarfile [
           (to execute a jar file)

Wenn ich dann versuche:
E:\osmosis>java -jar osmosis.jar --read-xml E:/gis_customizing_09/niedersachsen_osm/niedersachsen.osm --bb lef
ght=8.1694 top=52.3537 bottom=52.217 --write-xml E:/gis_customizing_09/niedersachsen_osm/osnabrueck3.osm


.....dann kommt leider nur:

10.11.2009 12:08:26 org.openstreetmap.osmosis.core.Osmosis run
INFO: Osmosis Version 0.31
10.11.2009 12:08:26 org.openstreetmap.osmosis.core.Osmosis main
SCHWERWIEGEND: Execution aborted.
java.lang.NoClassDefFoundError: org/java/plugin/PluginLifecycleException
        at org.openstreetmap.osmosis.core.Osmosis.run(Osmosis.java:73)
        at org.openstreetmap.osmosis.core.Osmosis.main(Osmosis.java:30)
Caused by: java.lang.ClassNotFoundException: org.java.plugin.PluginLifecycleException
        at java.net.URLClassLoader$1.run(Unknown Source)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(Unknown Source)


Ich stehe da wirklich auf dem Schlauch (bin völlig unbedarft in java, noch nie damit zu tun gehabt), kann es irgendwie an Java-Versionen liegen (aber dann hätte das ältere Osmosis
wahrscheinlich auch nicht funktioniert, und da lief ja alles)?

Viele Grüße, Kai

-------- Original-Nachricht --------
> Datum: Tue, 10 Nov 2009 11:46:18 +0100
> Von: marcus.wolschon at googlemail.com
> An: Kai Behncke <Kai-Behncke at gmx.de>
> CC: talk-de at openstreetmap.org
> Betreff: Re: [Talk-de] Problem mit aktueller Osmosis-Version.

> On Tue, 10 Nov 2009 11:38:09 +0100, "Kai Behncke" <Kai-Behncke at gmx.de>
> wrote:
> > Hallo Marcus,
> > 
> >> 
> >> Die Klasse ist mit der jpf.jar hinzu gekommen.
> >> 
> >> Kannst du mal deine osmosis.bat schicken?
> >> Ich denke da fehlt ein Eintrag im Classpath.
> >> 
> >> Marcus
> > 
> > ich habe eine Fehlermeldung bekommen, als ich Dir die osmosis.zip
> geschickt
> > habe (die Batch-Datei),
> > Du kannst Diese aber auch herunterladen unter:
> > 
> > http://www.selbstverwaltung-bundesweit.de/osmosis.zip (enthält nur die
> 
> 
> ja, da fehlt die lib/test/jpf-1.5.jar in -cp 
> 
> Marcus

-- 
GRATIS für alle GMX-Mitglieder: Die maxdome Movie-FLAT!
Jetzt freischalten unter http://portal.gmx.net/de/go/maxdome01




Mehr Informationen über die Mailingliste Talk-de