[Talk-de] Problem mit osm.pbf

Wolfgang wolfgang at ivkasogis.de
Di Dez 7 14:58:23 UTC 2010


Hallo,
Am Dienstag 07 Dezember 2010 12:29:01 schrieb Christian H. Bruhn:
> am Montag, 6. Dezember 2010 um 19:42 schrieb aighes:
> > noch eine Ergänzung, osmosis 0.38 macht auch Probleme. Bei einem
> 
> Unter Windows oder Linux? Ich nutze Osmosis unter Windows und habe
> damit auch Probleme.
> 
> > europe-Extrakt ist osmosis nach ca. 25sec durch. Es gibt keine Fehler,
> > allerdings sin die Dateien nur ein paar mb groß.
> 
> Ich habe schon seit Anfang Probleme mit dem neuen Format. Ich dachte,
> es wäre eine Möglichkeit, ein Planet-File aktuell zu halten. Doch die
> resultierenden Dateien waren auch viel zu klein; Osmosis brach auch
> immer ohne Fehlermeldung ab. Ich habe das schon mit unterschiedlichen
> Osmosis-Versionen und mehreren Planet-Files ausprobiert, auch mit
> diversen Java-Versionen.
> 
> Ich habe den Fehler schon vor einiger Zeit auf der dev-Liste und im
> Forum geschildert, aber ohne Erfolg. Ich habe allerdings auch noch
> nicht die entstandenen (kaputten) PBF-Dateien untersucht, ob man
> erkennt, was drin ist und was nicht.
> 
> Wenn ich Osmosis aus einer Linux-VM über die gleichen Dateien laufen
> lasse, dann klappt es. Ist aber nicht so komfortabel, immer erst Linux
> aufzurufen und vor allem habe ich dort noch nicht geschafft eine
> simple Batch-Datei zu erzeugen.
> 

so einen Fehler sollte man doch recht einfach finden können. Mal eben mit 
einem handelsüblichen Editor die Datei öffnen und nachsehen, ob der Inhalt 
sinnvoll ist...      :-)

duck und wech

Wolfgang




Mehr Informationen über die Mailingliste Talk-de