[Talk-de] Scanaerial-Plugin und Aerowest-Luftbilder

Carsten Gerlach daswaldhorn at gmx.de
Do Aug 18 17:09:07 UTC 2011


Hallo zusammen,

ich möchte gern das Scanaerial-Plugin nutzen um von den Aerowest-Luftbildern 
Objekte abzuzeichnen. Dazu habe ich Scanaerial laut Anleitung [1] 
eingerichtet; mit dem standardmäßig eingestellten Bing funktioniert es auch 
wie gewünscht. Ebenso habe ich für die Aerowest-Bilder einen lokalen Mapserver 
[2] eingerichtet, der auch mit JOSM problemlos funktioniert. Damit Scanaerial 
nun die Aerowestbilder nutzt, habe ich in der scanaerial.cfg die Zeile

wms_server_url = http://wms.latlon.org/?layers=bing&

in

wms_server_url = http://127.0.0.1/cgi-
bin/mapserv?map=/home/carsten/Dokumente/OSM/Aerowest/mapserver/osm.map&

geändert, halt auf die WMS-Angabe, die auch im Mapfile osm.map des Mapservers 
angegeben ist.

Starte ich nun scanaerial, läuft der entsprechende python-Prozess auf nahezu 
100% CPU-Last und wird nicht fertig... nach ca. 1 Stunde hab ich in mal 
abgebrochen.

In der osm.map des Mapservers taucht zweimal die Zeile

"wms_srs" "EPSG:4326"

auf, was mit veranlasst hat, auch in der scanaerial.cfg einen Versuch mit

projection = EPSG:4326

zu wagen. Einen Unterschied zwischen dieser Projektion und der standardmäßigen 
von EPSG:3857 habe ich nicht feststellen können.

An welcher Stellschraube kann ich jetzt noch drehen, um Scanaerial wie 
gewünscht zum laufen zu bringen? Vielleicht liest ja ein Scanaerial-Entwickler 
mit und weis Rat.


Vielen Dank und Gruß, Carsten

PS: Ich nutze Ubuntu 11.04, auf einem 64-bit-System.



[1] http://wiki.openstreetmap.org/wiki/Scanaerial
[2] 
http://wiki.openstreetmap.org/wiki/DE:Installation_und_Verwendung_von_MapServer_f%C3%BCr_Aerowest_Luftbilder




Mehr Informationen über die Mailingliste Talk-de