<div dir="ltr">J'ai un peu "tittillé" le passage à niveau en le recréant sur un nouveau nœud et supprimant l'ancien nœud, ça règle le problème du chemin parasite (les mises à jour de rendu sont en cours pour les niveaux de zoom plus bas). Au passage j'ai un peu amélioré la précision de placement de la ligne de chemin de fer.</div><div class="gmail_extra"><br><div class="gmail_quote">Le 9 août 2018 à 23:28, Philippe Verdy <span dir="ltr"><<a href="mailto:verdy_p@wanadoo.fr" target="_blank">verdy_p@wanadoo.fr</a>></span> a écrit :<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr">La modif n'a pas d'effet sur le chemin parasite, il semble que le rendu curieux soit lié au fait que le serveur de rendu a bien deux chemins mais il n'en trouve qu'un correctement tagué dans sa base mais avec une géométrie incomplète, et l'autre vient de la géométrie qu'il voit mais pas tagué correctement. Un changeset est visiblement passé sur ce serveur, mais visiblement pas au complet, il était peut-être tronqué quand il a été chargé, et cela a laissé ces parasites avec des modifs incomplètement chargées sur sa base esclave.<div>Je reste persuadé que c'est un problème de remise en route des serveurs migré de Londres à Amsterdam: suite à l'arrêt il a du manquer certains diffs ou des diffs incomplets ou un problème d'espace disque ou d'espace temporaire saturé (suite aux scripts de migration) ou de connectivité temporaire (erreurs de caches DNS par exemple) a pu causer ce bogue. On voit ces bogues à divers endroits, tous autour des modifications effectuées durant une seule heure environ.</div><div><br></div><div>La désynchronisation des "diffs" semble bien la bonne piste. Cela est déjà arrivé aussi sur les serveurs de rendu d'OSM France et chaque fois il a fallu repartir en chargeant un dump complet postérieur aux problèmes de diffs constatés puis rechargeant les autres nouveaux diffs émis depuis ce dump.</div><div><br></div><div>En terme de tags je ne vois pas de problème, et les rendus d'OSM France ou Allemagne ou Mapquest ne sont pas impactés ici (mais eux n'ont pas changé d'hébergement et de config réseau pendant ce temps). De toute façon comme le bogue est connu et signalé, OSM.org trouvera bien une solution (quitte à arrêter deux de ses 4 serveurs de rendu et avoir un peu plus de "lag" pendant ce temps là, le temps de recharger leur base).</div><div><br></div><div>En tout cas une chose est sure, cela ne vient pas des caches de tuiles (sur les 21 sites du CDN d'OSM.org) : ils sont bien à jour et pas en retard.</div><div><br></div></div><div class="gmail_extra"><br><div class="gmail_quote"><div><div class="h5">Le 9 août 2018 à 22:46,  <span dir="ltr"><<a href="mailto:osm.sanspourriel@spamgourmet.com" target="_blank">osm.sanspourriel@spamgourmet.<wbr>com</a>></span> a écrit :<br></div></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div><div class="h5">
  
    
  
  <div text="#000000" bgcolor="transparent"><span>
    <p>Le 09/08/2018 à 19:09, marc marc - <a class="m_5084977875929061244m_8643609511759849515moz-txt-link-abbreviated" href="mailto:marc_marc_irc@hotmail.com" target="_blank">marc_marc_irc@hotmail.com</a> a
      écrit :<br>
    </p>
    <blockquote type="cite">
      <pre>si tu regardes le point qui a visuelement un problème
<a class="m_5084977875929061244m_8643609511759849515moz-txt-link-freetext" href="https://www.openstreetmap.org/node/252291030" target="_blank">https://www.openstreetmap.org/<wbr>node/252291030</a>
il ne fait plus partie que d'un rail. donc problèe entre temps résolu
et lag dans la maj du rendu (il y a un bug majeur sur 2 serveur de rendu 
<a href="http://osm.org" target="_blank">osm.org</a>)
</pre>
    </blockquote></span>
    Ça fait 9 mois que <a href="https://www.openstreetmap.org/user/baleineaux" target="_blank">baleineaux</a>
    l'a mis comme level_crossing d'un seul éléments ferré et d'un non
    ferré.<br>
    Et 12 jours qu'il a mis à jour la liaison <a href="https://www.openstreetmap.org/way/262550757#map=12/47.5247/-3.0738&layers=H" target="_blank">https://www.openstreetmap.org/<wbr>way/262550757#map=12/47.5247/-<wbr>3.0738&layers=H</a><br>
    <br>
    Je vois que Philippe a titillé le chemin en lui mettant sa référence
    (et en supposant une vitesse de 80 km/h).<br>
    La référence est bien affichée mais au niveau 18 on a un curieux
    rendu : <a href="https://www.openstreetmap.org/query?lat=47.67901&lon=-3.02167#map=18/47.67904/-3.02191" target="_blank">https://www.openstreetmap.org/<wbr>query?lat=47.67901&lon=-3.0216<wbr>7#map=18/47.67904/-3.02191</a><br>
    <br>
    <a href="https://a.tile.openstreetmap.org/18/128871/91473.png" target="_blank">https://a.tile.openstreetmap.o<wbr>rg/18/128871/91473.png</a><br>
    <img src="https://a.tile.openstreetmap.org/18/128871/91473.png" alt="https://a.tile.openstreetmap.org/18/128871/91473.png"><br>
    Sachant que le railway va de part et d'autre du PAN...<br>
    <br>
    N.B. : le décalage horaire ne me semble pas une bonne piste.<br>
    Jean-Yvon<br>
  </div>

<br></div></div><span class="">______________________________<wbr>_________________<br>
Talk-fr mailing list<br>
<a href="mailto:Talk-fr@openstreetmap.org" target="_blank">Talk-fr@openstreetmap.org</a><br>
<a href="https://lists.openstreetmap.org/listinfo/talk-fr" rel="noreferrer" target="_blank">https://lists.openstreetmap.or<wbr>g/listinfo/talk-fr</a><br>
<br></span></blockquote></div><br></div>
</blockquote></div><br></div>