[Talk-GB] Funny with Mapnik?

Jon Burgess jburgess777 at googlemail.com
Fri Oct 23 15:59:18 BST 2009


On Fri, 2009-10-23 at 15:21 +0100, Ian Caldwell wrote:
> I put a few roads in last night and when I checked them this morning
> they were missing from the level 14,15,16 in Maplink. I then added a
> turning circle I had missed. About 1/2 hour ago they were missing from
> levels 14-18.
> 
> They are all there in Osmarender.
> 
> location is http://www.openstreetmap.org/?lat=52.11225&lon=-2.29763&zoom=17&layers=0B00FTF
> Streets Moatway Moat Cresent and Five Oaks Close.
> 
> As I check for this mail parts of them have appeared in level 18. but
> when I do a status on the showing bit I get
> http://tile.openstreetmap.org/18/129396/86455.png/status "Tile is
> clean. Last rendered at Thu Oct 22 22:38:30 2009"
> 
> but were it is missing status shows
> http://tile.openstreetmap.org/18/129396/86456.png/status "Tile is
> clean. Last rendered at Fri Oct 23 14:16:29 2009"
> 
> So the later tile has the streets missing
> 
> Have I done anything wrong or is it Mapnik?

That was my fault. I started importing this weeks planet dump on
Thursday evening. The DB is in the process of applying the updates from
Wednesday to now in order to catch up with the recent changes. When I
started this diff process I initially forgot to turn off the tile
invalidation so it ended up rendering tiles with data which could have
been older than that available previously.

That is why the tiles from Thursday show the recent data but the tiles
rendered today do not. The diffs have currently got as far as Thursday
midday and probably will not catch up until some time in the early hours
tomorrow morning.

	Jon






More information about the Talk-GB mailing list