[Talk-it] R: Navit on Windows CE

iiizio iiizio iiizio.iiizio at gmail.com
Wed Aug 11 17:56:12 BST 2010


2010/8/11 Simone Saviolo <simone.saviolo at gmail.com>:
..
> Poi ho cercato di aggiungere mappe scaricate da OSM (non ho intenzione
> di andare a Monaco entro breve). Qua è ricominciato il fallimento. Mi
> sono fatto due copie di Navit, e su una ho modificato il navit.xml e
> ho aggiunto una mappa con il nord Italia (all'incirca da Ginevra a
> Pescara) con un bin da 180 MB circa dopo aver disattivato quella di
> Monaco; lanciando Navit ottengo un crash, e il log finisce con "no
> graphics". Lo stesso succede con una mappa più piccola (Piemonte e
> Liguria, circa 60 MB).

Io per prova ho scaricato qui
(http://downloads.cloudmade.com/europe/italy#downloads_breadcrumbs) la
mappa dell'Italia (la italy.navit.bin.zip) che ho unzippato nella SD.
Poi va puntata dal file di configurazione:
<mapset enabled="yes">
	<map type="binfile" enabled="yes" data="\Scheda di
memoria\OSM\italy.navit.bin"/>
</mapset>


> Sai inoltre dirmi cosa bisogna fare di preciso per poter usare il GPS?
> Devo impostare la source "wince:com2:" su ogni profilo? Ci sono altri
> accorgimenti?

Questo è quello che ho messo sul htc kaiser:
<vehicle name="Local GPS" profilename="car" enabled="yes" active="1"
source="wince:com4:" baudrate="4800">
	<!-- Navit can write a tracklog in several formats (gpx, nmea or textfile): -->
	<log enabled="no" type="gpx"
attr_types="position_time_iso8601,position_direction,position_speed,profilename,position_radius"
data="track_%Y%m%d-%%i.gpx" flush_size="1000" flush_time="30"/>
</vehicle>


Non riesco a fare la ricerca per città, via, numero (la gui ha qualche
problema) e non ho capito se c'é modo di ricalcolare il percorso senza
ridefinire la destinazione. Qualcuno ha idea come fare?


iiizio



More information about the Talk-it mailing list