[Talk-it] Wikipedia-tag-in-OSM: da OSM a Wikipedia (versione beta)

Cristian Consonni kikkocristian a gmail.com
Mer 19 Feb 2014 15:50:05 UTC


Il 19 febbraio 2014 11:38, Andrea De Gradi <dega180 a gmail.com> ha scritto:
> Ti prego di non prendermi come uno che non gli va mai bene niente, sono
> contento del lavoro che stai facendo ed è già ad un ottimo punto, voglio
> solo dare dei suggerimenti su come migliorarlo, i suggerimenti li do da non
> esperto programmatore quindi molte volte non conosco la fattibilità di
> quello che propongo.

Fai bene invece, tu segnala tutto. L'ho pubblicato apposta per testarlo :-)

> Ho notato che la mappa che viene utilizzata nel tool rappresenta molti meno
> oggetti della mappa utilizzata dal sito di OpenStreetMap. Questa cosa l'ho
> notata confrontando per esempio la mappa della Stazione Palestrina mostrata
> dal tool con quella mostrata da OSM. In particolare non si vedono gli
> edifici in torno alla stazione e soprattutto non si vede il nome della
> stazione.

Dipende da CloudMade (che è il servizio che fornisce le tile).
Ho provato a cambiare lo stile della mappa, ma non mi sembra che
aggiunga dei POI.
(c'è da dire che gli stili sono tanti: http://maps.cloudmade.com/editor).
Ho provato a usare un altro tile server; ora come ora sto usando MapQuest.
(però, ad esempio, vedo che non ci sono le fermate dei bus, che
nell'altro stile c'erano).

Il 19 febbraio 2014 11:51, Andrea De Gradi <dega180 a gmail.com> ha scritto:
> Un'altra cosa ancora che ho trovato è che se scelgo di riposizionare il
> marker il template coord che mi viene proposto non conta del
> riposizionamento del marker ma viene compilato con le coordinate "iniziali"
> cioè quelle che mi compaiono appena clicco sul simbolo con la W.

Questo succede perché cambio i nomi agli elementi html e poi mi
dimentico di aggiornare il javascript.
-___-''
Fixato.

Ripeto, non farti problemi anzi sono io a doverti ringraziare.

Ciao,

C



Maggiori informazioni sulla lista Talk-it