[Talk-it] Wikipedia-tag-in-OSM: da OSM a Wikipedia (versione beta)

Simone F. groppo8 a gmail.com
Sab 22 Feb 2014 09:04:45 UTC


Ciao

Il giorno 20 febbraio 2014 11:39, Cristian Consonni <kikkocristian at gmail.com
> ha scritto:

> Il 19 febbraio 2014 16:50, Cristian Consonni <kikkocristian at gmail.com>
> ha scritto:
> > Il 19 febbraio 2014 11:38, Andrea De Gradi <dega180 at gmail.com> ha
> scritto:
> >> Ho notato che la mappa che viene utilizzata nel tool rappresenta molti
> meno
> >> oggetti della mappa utilizzata dal sito di OpenStreetMap.
>
...

> > Dipende da CloudMade (che  il servizio che fornisce le tile).
> > Ho provato a cambiare lo stile della mappa, ma non mi sembra che
> > aggiunga dei POI.
> > (c' da dire che gli stili sono tanti: http://maps.cloudmade.com/editor
> ).
> > Ho provato a usare un altro tile server; ora come ora sto usando
> MapQuest.
> > (per, ad esempio, vedo che non ci sono le fermate dei bus, che
> > nell'altro stile c'erano).
>
> Ok, ho aggiunto diversi possili layer. Cos  meglio?
>
>
In alternativa potresti usare lo "stile classico" di OSM:
var osmLayer = L.tileLayer('http://{s}.tile.osm.org/{z}/{x}/{y}.png', {
    attribution: '© <a href="http://osm.org/copyright">OpenStreetMap</a>
contributors',
});

Ho notato che nella mappa vengono caricate le tiles di tutti i base layers.
https://dl.dropboxusercontent.com/u/41550819/OSM/app.png

Probabilmente  dovuto a questo:
"Also note that when using multiple base layers, only one of them should be
added to the map at instantiation, but all of them should be present in the
base layers object when creating the layers control."
http://leafletjs.com/examples/layers-control.html

Togliendo la spunta a "Centroide in OSM" scompare anche la mappa
sottostante (forse  legato al problema sopra?)


Ciao,
Simone F.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.org/pipermail/talk-it/attachments/20140222/fa482676/attachment.html>


Maggiori informazioni sulla lista Talk-it