[Talk-it] Osmose: gli edit non funzionano

Andrea Albani aobani a gmail.com
Gio 28 Feb 2019 18:31:58 UTC


Ho appena fatto una modifica ad un nodo [0] con l'editor integrato in
Osmose aggiungendo 2 tag e modificandone altri 2 senza riscontrare problemi.
Confermo che il changeset non viene chiuso immediatamente, neanche dopo
avere fatto logoff da Osmose e anche togliendo il flag dalla voce
"Riutilizza changeset" durante il salvataggio

Ciao

[0] https://www.openstreetmap.org/node/1838212259




Il giorno gio 28 feb 2019 alle ore 11:26 Canfe News <canfe.news a gmail.com>
ha scritto:

> Ti ringrazio per la pronta risposta, ma non credo sia lì il problema.
> Mi ricordo bene quel changeset: ho volutamente editato da ID bench e
> shelter mentre platform l'ho aggiunta da Osmose, solo per non perdere il
> lavoro come mi era successo altre volte.
> L'ideale sarebbe che qualcuno DA Osmose correggesse EDITANDO qualche tag
> per poi vedere se arrivano o no sul DB.
> (se invece AGGIUNGE dei tag, quello sì, funziona, come ci si aspetta)
>
> Il giorno mer 27 feb 2019 alle ore 22:59 Andrea Albani <aobani a gmail.com>
> ha scritto:
>
>> Ciao,
>>
>> guardando la tua history vedo che il changeset relativo all'edit diretto
>> in osmose [0] ha come ora di apertura 16:23, ma viene chiuso alle 17:34,
>> ora in cui i change apportati  (public_transport=platform) vengono
>> consolidati sul db.
>> Dentro ad esempio ci sono le 2 fermate di "Barbania (fraz. Piana)" che
>> sono oggetto di un altro changeset [1] creato con iD (aperto e chiuso alle
>> 16:33) in cui cambi i valori dei tag bench e shelter da unknown a no.
>> La mia ipotesi è che i valori nuovi di questi 2 tag fossero anche nel
>> changeset di osmose, che essendo però stato consolidato dopo la chiusura
>> del changeset fatto con iD, non appaiono come modificati da quello di
>> osmose.
>>
>> Puoi verificare se quanto sopra è corretto apportando una modifica in
>> osmose e aspettando che questa appaia nella tua changeset history per poi
>> controllare se contiene tutte le modifiche attese.
>>
>> Ciao
>>
>> [0] https://www.openstreetmap.org/api/0.6/changeset/67623366
>> [1] https://www.openstreetmap.org/api/0.6/changeset/67623673
>>
>>
>> Il giorno mer 27 feb 2019 alle ore 20:57 canfe <canfe.news a gmail.com> ha
>> scritto:
>>
>>> Ho scoperto che su Osmose se si edita *da *Osmose, la segnalazione
>>> sparisce
>>> ma in realtà il DB di OSM *non *viene aggiornato.
>>> Capita anche a voi?
>>>
>>> Caso pratico:
>>> ho editato parecchie pensiline bus.
>>> Osmose segnale un errore con pin marrone perché shelter e bench sono
>>> /unknown/.
>>> Con mapillary ho controllato ed ho editato *dall'interno di Osmose*
>>> mettendo
>>> yes o no.
>>> Il pin sparisce e ne compare uno azzurro che indica che bisogna
>>> aggiungere
>>> /platform/.
>>> Faccio il fix proposto da Osmose *utilizzando *Osmose.
>>> Il pin sparisce.
>>> Effetto sul DB: shelter e bench *non *aggiornati, platform *aggiunta *sì.
>>>
>>> (ovviamente ho fatto il "save" su Osmose).
>>>
>>> Ferruccio Cantone
>>>
>>>
>>>
>>> --
>>> Sent from: http://gis.19327.n8.nabble.com/Italy-General-f5324174.html
>>>
>>> _______________________________________________
>>> Talk-it mailing list
>>> Talk-it a openstreetmap.org
>>> https://lists.openstreetmap.org/listinfo/talk-it
>>>
>> _______________________________________________
>> Talk-it mailing list
>> Talk-it a openstreetmap.org
>> https://lists.openstreetmap.org/listinfo/talk-it
>>
> _______________________________________________
> Talk-it mailing list
> Talk-it a openstreetmap.org
> https://lists.openstreetmap.org/listinfo/talk-it
>
-------------- parte successiva --------------
Un allegato HTML è stato rimosso...
URL: <http://lists.openstreetmap.org/pipermail/talk-it/attachments/20190228/1a4e4e08/attachment.html>


Maggiori informazioni sulla lista Talk-it