[OSM-talk] Strange api behaviour

SteveC steve at asklater.com
Wed Mar 15 21:03:31 GMT 2006


* @ 15/03/06 06:08:12 PM openstreetmap-L at gj0.net wrote:
> And now it's stopped working again.
> 
> This: http://www.openstreetmap.org/api/0.2/map?bbox=-0.5,51.3,-0.4,51.4
> 
> Returns stuff like this again:

Yes. This has highlighted that it isn't very practical as it stands to
support old and new API versions. With 0.4 I'll introduce some clearer
versioning, so something like /api/current_version will tell you what to
use and each editor can decide what to do. I'll give a weeks warning
announcement so people can update their code too. As we approach 1.0
this will matter less and less as things won't change so much.

have fun,

SteveC steve at asklater.com http://www.asklater.com/steve/




More information about the talk mailing list