[OSM-talk] Still getting "500 Internal Server Error"

Joerg Ostertag openstreetmap at ostertag.name
Sun Mar 19 21:13:42 GMT 2006


On Friday 17 March 2006 08:53, Joerg Ostertag wrote:
> Hi,
>
> I'm trying to browse or do a wget on
> http://www.openstreetmap.org/api/0.3/map?bbox=40.0,10.0,40.1,10.1
> and the get an:
>   500 Internal Server Error
>
> Do you have any Idea If I'm doing something wrong or if it's a temporary
> Server Issue?
>
> If I use the 0.2 API I get the following:
>
> http://www.openstreetmap.org/api/0.2/map?bbox=40,10,50,20
> Not Found
> The requested URL /ruby/api/0.2/map.rb was not found on this server.

I tried to follow the instructions on 
  http://wiki.openstreetmap.org/index.php/REST

When the 0.2 API was actice it worked, but now it looks like i 
can't get any data for any area with the map?bbox= method.

With the 0.3 API on the Server active I try this request:
- SNIP -----------------------------------------------------------
wget 'http://www.openstreetmap.org/api/0.3/map?bbox=41.1111,10.1111,42.1112,11.1112'
http://www.openstreetmap.org/api/0.3/map?bbox=41.1111,10.1111,42.1112,11.1112:
22:07:34 FEHLER 500: Internal Server Error.
- SNIP -----------------------------------------------------------


Trying another request method works:
- SNIP -----------------------------------------------------------
wget -O - 'http://www.openstreetmap.org/api/0.3/segment/113991' | gzip -dc
<?xml version="1.0"?>
<osm version="0.3" generator="OpenStreetMap server">
  <segment id="113991" from="155337" to="155328">
    <tag k="name" v="Camden Road"/>
  </segment>
</osm>
- SNIP -----------------------------------------------------------

But I think to get all Street Data for an area the best method 
seems to be map?bbox=. So any hint will be greatly appreciated.

-

Joerg




More information about the talk mailing list