[OSM-talk] Can not remove a way from a relation

Richard Bullock rb357 at cantab.net
Wed Jan 28 00:53:46 GMT 2009


>>> nodes. Using the script I found that the relation (21359) contains a
>>> reference to way 8135282, which was deleted on January 5th
>>> (http://www.openstreetmap.org/browse/way/8135282/history). I tried to
>>> remove the way from the relation, but get the same error while
>>> uploading.
>>>
>>
>> There could be another way that has been deleted, or there is a node
>> that is reference by a way that is missing.
>

I've managed to undelete the way - and using Potlatch remove the way from 
both relations (the E20 and E6 Euro-route relations) - and then re-delete 
the way.

All seems to have worked ok at first glance - and the way is no longer 
showing in the list of ways in 
http://www.openstreetmap.org/browse/relation/21359.

However - I tried to use JOSM to add a way to the relation - and it still 
gave a "412 Precondition Failed" response.

Sounds like there could be other ways with referential problems somewhere 
along the line.

Richard B 





More information about the talk mailing list