[OSM-talk] Wiki VisualEditor (Was: Wiki translate extension)

Rob Nickerson rob.j.nickerson at gmail.com
Thu Jul 24 23:13:32 UTC 2014


>> extension moved from requiring mediawiki 1.23 to requiring mediawiki 1.24
>> which is still in development.
>
>Can't you just use the old version that worked with 1.23?
>

VisualEditor is still in development. MediaWiki provide an extension so
that non Wikimedia sites can start to use it but as of June 2014 this
extension has required mw 1.24

https://www.mediawiki.org/w/index.php?title=Extension%3AVisualEditor&diff=1021728&oldid=1021727

Any version that worked with mw 1.23 was considered unstable and hence
Grant was unwilling to install it for OSM's wiki. I don't blame Grant - he
works hard to keep everything up and running and as such a "stable" version
is a reasonable request. If anything it's the visualeditor developers who
need to hurry up and stop pushing the requirements up - mw 1.22, mw 1.23,
mw 1.24, ... when will it stop!!

Rob
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.org/pipermail/talk/attachments/20140725/cd6c42be/attachment.html>


More information about the talk mailing list