[OSM-talk] JOSM Tile Cache

Mike Thompson miketho16 at gmail.com
Thu Apr 23 20:58:40 UTC 2015


I am using JOSM version 8109 on Windows 7.

I would like to flush JOSM's "OpenStreetMap (Mapnik)" tile cache. With the
"OpenStreetMap (Mapnik) layer displayed, I right clicked on the map, and
then clicked on "Flush Tile Cache", but I still see outdated tiles (when
compared to the openstreetmap.org website - I made sure both were on the
same zoom level). I also tried, in conjunction with the above, removing and
re-adding the "OpenStreetMap (Mapnik)" layer, as well as restarting JOSM.

Finally I tried renaming the "OpenStreetMap (Mapnik)" folder in the
following location: C:\Users\<username>\AppData\Local\JOSM\cache\tms
 (this is the location the "imagery.tms.tilecache preference is set to).
Only after doing this were the tiles updated.

Does the "Flush Tile Cache" work? I saw a bug report[1] about something
like this, but it was closed four years ago as "fixed."  If it is working,
am I using it correctly?


Thanks,

Mike

[1] https://josm.openstreetmap.de/ticket/6109
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.org/pipermail/talk/attachments/20150423/5fc09d31/attachment.html>


More information about the talk mailing list