[OSM-talk] JOSM Tile Cache

Mike Thompson miketho16 at gmail.com
Tue Apr 28 02:47:08 UTC 2015


Paul,

I tested version 8287. I can go ahead and submit a bug report, but wanted
to let you know the results directly.  It seems that refreshed Mapnik tiles
will only show up after they show up in a browser window open to
www.openstreetmap.org.  Let me explain.  I make a change with JOSM, upload
it and then, with Mapnik as the imagery layer, right click on the image and
click "Flush Tile Cache."  The screen flickers, but the tiles appear the
same. I repeat the "Flush Tile Cache" several times over the next few
minutes with the same result. I go to the browser (Chrome 42.0.2311.90
m) window
open to www.openstreetmap.org the same area and zoom level, and hit F5.
Updated tiles are displayed. I then return to JOSM, "Flush Tile Cache" and
then the updated tiles are displayed in JOSM as well.  To attempt to prove
that it isn't just coincidence,  I have repeated the whole test a number of
times with the same results.  Is it possible that JOSM uses the same tile
cache as Chrome (but is unable to flush it directly)?

MIke

On Sun, Apr 26, 2015 at 8:26 AM, Mike Thompson <miketho16 at gmail.com> wrote:

> Paul,
>
> Thanks for your reply and for the information.  I test with the
> development version.
>
> Mike
>
> On Sun, Apr 26, 2015 at 8:20 AM, Paul Hartmann <phaaurlt at gmail.com> wrote:
>
>> Hi Mike,
>>
>> There has been a major rework of the TMS cache back end in version
>> 8168-8186. If you can still reproduce this problem with the current
>> development build or with the upcoming release, then please don't hesitate
>> to report it directly on the JOSM bug tracker!
>>
>> Paul
>>
>>
>> On 23.04.2015 22:58, Mike Thompson wrote:
>>
>>> I am using JOSM version 8109 on Windows 7.
>>>
>>> I would like to flush JOSM's "OpenStreetMap (Mapnik)" tile cache. With
>>> the
>>> "OpenStreetMap (Mapnik) layer displayed, I right clicked on the map, and
>>> then clicked on "Flush Tile Cache", but I still see outdated tiles (when
>>> compared to the openstreetmap.org website - I made sure both were on the
>>> same zoom level). I also tried, in conjunction with the above, removing
>>> and
>>> re-adding the "OpenStreetMap (Mapnik)" layer, as well as restarting JOSM.
>>>
>>> Finally I tried renaming the "OpenStreetMap (Mapnik)" folder in the
>>> following location: C:\Users\<username>\AppData\Local\JOSM\cache\tms
>>>   (this is the location the "imagery.tms.tilecache preference is set to).
>>> Only after doing this were the tiles updated.
>>>
>>> Does the "Flush Tile Cache" work? I saw a bug report[1] about something
>>> like this, but it was closed four years ago as "fixed."  If it is
>>> working,
>>> am I using it correctly?
>>>
>>>
>>> Thanks,
>>>
>>> Mike
>>>
>>> [1] https://josm.openstreetmap.de/ticket/6109
>>>
>>>
>>>
>>> _______________________________________________
>>> talk mailing list
>>> talk at openstreetmap.org
>>> https://lists.openstreetmap.org/listinfo/talk
>>>
>>>
>>
>> _______________________________________________
>> talk mailing list
>> talk at openstreetmap.org
>> https://lists.openstreetmap.org/listinfo/talk
>>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.org/pipermail/talk/attachments/20150427/80ec96fa/attachment.html>


More information about the talk mailing list