[OSM-talk] Mapnik rendering questions

Maarten Deen mdeen at xs4all.nl
Sun Jul 9 06:36:05 UTC 2017


On 2017-07-08 10:44, Martin Koppenhoefer wrote:
> sent from a phone
> 
>> On 8. Jul 2017, at 08:39, Maarten Deen <mdeen at xs4all.nl> wrote:
>> 
>> You used to be able to invalidate a tile, but that does not work 
>> anymore
> 
> 
> AFAIK it still works, although it is rather complicated now to get the
> tile URL, and there's reluctance from the admin to expose them in a
> convenient way (right click menu)
> 
> I'm doing it in firefox by hitting ctrl+i and browsing through the
> media urls until I find the right tile...

It took me a while to get to the correct tile on zoom 15 [1] but it was 
clean and rendered at 30-6. I marked it dirty and it got rendered. In 
the process I noticed that z13 appeard correct too.
z16 is still incorrect [2]
"Tile is clean. Last rendered at Wed Jul 05 20:47:35 2017. Last accessed 
at Sat Jul 08 18:55:11 2017. Stored in 
file:///srv/tile.openstreetmap.org/tiles/default/16/0/149/15/249/0.meta"
I did my edit on the 6th. Why does the renderer not see that I deleted 
an item and mark the tile dirty?

I have to say: it is a nuisance that you can not get this information 
easily. Please someone who is in the map development and reads this: add 
an item to the right-click menu where you can see tile status. There is 
a complaint about it on the dutch forum as well. [3]

[1] http://tile.openstreetmap.org/15/18552/12232.png
[2] http://tile.openstreetmap.org/16/37105/24465.png/status
[3] https://forum.openstreetmap.org/viewtopic.php?pid=653871#p653871

Maarten



More information about the talk mailing list