Mike,<div><br></div><div>From your description it looks more like caching on the server side than on your computer. You can verify that by using different browsers or computers.</div><div><br></div><div>Hitting force reload in browser may generate new tile on the server and there is no such functionality in JOSM right now.</div><div><br></div><div>What can be implemented would be to avoid using server caches when you right-click and choose to reload the tiles.</div><div><br></div><div>As I'm digging in that area currently, I'll look into this.</div><div><br></div><div>Cheers,</div><div><br></div><div>Wiktor<br><br>On Tuesday, April 28, 2015, Mike Thompson <<a href="mailto:miketho16@gmail.com">miketho16@gmail.com</a>> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr">Paul,<div><br></div><div>I tested version 8287. I can go ahead and submit a bug report, but wanted to let you know the results directly.  It seems that refreshed Mapnik tiles will only show up after they show up in a browser window open to <a href="http://www.openstreetmap.org" target="_blank">www.openstreetmap.org</a>.  Let me explain.  I make a change with JOSM, upload it and then, with Mapnik as the imagery layer, right click on the image and click "Flush Tile Cache."  The screen flickers, but the tiles appear the same. I repeat the "Flush Tile Cache" several times over the next few minutes with the same result. I go to the browser (Chrome <span style="color:rgb(48,57,66);font-family:Tahoma,sans-serif;font-size:12px">42.0.2311.90 m) </span>window open to <a href="http://www.openstreetmap.org" target="_blank">www.openstreetmap.org</a> the same area and zoom level, and hit F5. Updated tiles are displayed. I then return to JOSM, "Flush Tile Cache" and then the updated tiles are displayed in JOSM as well.  To attempt to prove that it isn't just coincidence,  I have repeated the whole test a number of times with the same results.  Is it possible that JOSM uses the same tile cache as Chrome (but is unable to flush it directly)?</div><div><br></div><div>MIke</div></div><div class="gmail_extra"><br><div class="gmail_quote">On Sun, Apr 26, 2015 at 8:26 AM, Mike Thompson <span dir="ltr"><<a href="javascript:_e(%7B%7D,'cvml','miketho16@gmail.com');" target="_blank">miketho16@gmail.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr">Paul,<div><br></div><div>Thanks for your reply and for the information.  I test with the development version.</div><span><font color="#888888"><div><br></div><div>Mike</div></font></span></div><div><div><div class="gmail_extra"><br><div class="gmail_quote">On Sun, Apr 26, 2015 at 8:20 AM, Paul Hartmann <span dir="ltr"><<a href="javascript:_e(%7B%7D,'cvml','phaaurlt@gmail.com');" target="_blank">phaaurlt@gmail.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">Hi Mike,<br>
<br>
There has been a major rework of the TMS cache back end in version 8168-8186. If you can still reproduce this problem with the current development build or with the upcoming release, then please don't hesitate to report it directly on the JOSM bug tracker!<br>
<br>
Paul<div><div><br>
<br>
On 23.04.2015 22:58, Mike Thompson wrote:<br>
</div></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div><div>
I am using JOSM version 8109 on Windows 7.<br>
<br>
I would like to flush JOSM's "OpenStreetMap (Mapnik)" tile cache. With the<br>
"OpenStreetMap (Mapnik) layer displayed, I right clicked on the map, and<br>
then clicked on "Flush Tile Cache", but I still see outdated tiles (when<br>
compared to the <a href="http://openstreetmap.org" target="_blank">openstreetmap.org</a> website - I made sure both were on the<br>
same zoom level). I also tried, in conjunction with the above, removing and<br>
re-adding the "OpenStreetMap (Mapnik)" layer, as well as restarting JOSM.<br>
<br>
Finally I tried renaming the "OpenStreetMap (Mapnik)" folder in the<br>
following location: C:\Users\<username>\AppData\Local\JOSM\cache\tms<br>
  (this is the location the "imagery.tms.tilecache preference is set to).<br>
Only after doing this were the tiles updated.<br>
<br>
Does the "Flush Tile Cache" work? I saw a bug report[1] about something<br>
like this, but it was closed four years ago as "fixed."  If it is working,<br>
am I using it correctly?<br>
<br>
<br>
Thanks,<br>
<br>
Mike<br>
<br>
[1] <a href="https://josm.openstreetmap.de/ticket/6109" target="_blank">https://josm.openstreetmap.de/ticket/6109</a><br>
<br>
<br>
<br></div></div>
_______________________________________________<br>
talk mailing list<br>
<a href="javascript:_e(%7B%7D,'cvml','talk@openstreetmap.org');" target="_blank">talk@openstreetmap.org</a><br>
<a href="https://lists.openstreetmap.org/listinfo/talk" target="_blank">https://lists.openstreetmap.org/listinfo/talk</a><br>
<br>
</blockquote>
<br>
<br>
_______________________________________________<br>
talk mailing list<br>
<a href="javascript:_e(%7B%7D,'cvml','talk@openstreetmap.org');" target="_blank">talk@openstreetmap.org</a><br>
<a href="https://lists.openstreetmap.org/listinfo/talk" target="_blank">https://lists.openstreetmap.org/listinfo/talk</a><br>
</blockquote></div><br></div>
</div></div></blockquote></div><br></div>
</blockquote></div>