[Tile-serving] [mod_tile] osm.xml parse error (#9)

Benedek Sztankó notifications at github.com
Mon Apr 8 18:31:35 UTC 2013


Hello, i'd like to render with mod_tile and mapnik. When i run the renderd command, i got a parser error:

-----------
renderd[5981]: Rendering daemon started
renderd[5981]: Parsing section renderd
renderd[5981]: Parsing render section 0
renderd[5981]: Parsing section mapnik
renderd[5981]: Parsing section default
renderd[5981]: config renderd: unix socketname=/tmp/osm-renderd
renderd[5981]: config renderd: num_threads=4
renderd[5981]: config renderd: num_slaves=0
renderd[5981]: config renderd: tile_dir=/var/lib/mod_tile
renderd[5981]: config renderd: stats_file=/var/run/renderd/renderd.stats
renderd[5981]: config mapnik:  plugins_dir=/usr/local/lib/mapnik/input
renderd[5981]: config mapnik:  font_dir=/usr/share/fonts/truetype/ttf-dejavu
renderd[5981]: config mapnik:  font_dir_recurse=0
renderd[5981]: config renderd(0): Active
renderd[5981]: config renderd(0): unix socketname=/tmp/osm-renderd
renderd[5981]: config renderd(0): num_threads=4
renderd[5981]: config renderd(0): tile_dir=/var/lib/mod_tile
renderd[5981]: config renderd(0): stats_file=/var/run/renderd/renderd.stats
renderd[5981]: config map 0:   name(default) file(/root/src/mapnik-style/osm.xml) uri(/osm_tiles2/) htcp() host(localhost)
renderd[5981]: Initialising unix server socket on /tmp/osm-renderd
renderd[5981]: Created server socket 4
renderd[5981]: Renderd is using mapnik version 2.2.0
renderd[5981]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSansMono-Bold.ttf
renderd[5981]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSans.ttf
renderd[5981]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSerifCondensed-Italic.ttf
renderd[5981]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSerifCondensed-Bold.ttf
renderd[5981]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSans-BoldOblique.ttf
renderd[5981]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSerif-BoldItalic.ttf
renderd[5981]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSansCondensed-BoldOblique.ttf
renderd[5981]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSansCondensed.ttf
renderd[5981]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSans-ExtraLight.ttf
renderd[5981]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSerifCondensed-BoldItalic.ttf
renderd[5981]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSerif-Bold.ttf
renderd[5981]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSerif.ttf
renderd[5981]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSansCondensed-Bold.ttf
renderd[5981]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSansCondensed-Oblique.ttf
renderd[5981]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSerif-Italic.ttf
renderd[5981]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSans-Oblique.ttf
renderd[5981]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSansMono-BoldOblique.ttf
renderd[5981]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSerifCondensed.ttf
renderd[5981]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSansMono.ttf
renderd[5981]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSansMono-Oblique.ttf
renderd[5981]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSans-Bold.ttf
Running in foreground mode...
renderd[5981]: Starting stats thread
debug: init_storage_backend: initialising file storage backend at: /var/lib/mod_tile
debug: init_storage_backend: initialising file storage backend at: /var/lib/mod_tile
debug: init_storage_backend: initialising file storage backend at: /var/lib/mod_tile
debug: init_storage_backend: initialising file storage backend at: /var/lib/mod_tile
renderd[5981]: An error occurred while loading the map layer 'default': Failed to parse expression: "name" in style 'area-text' in TextSymbolizer at line 258 of '/root/src/mapnik-style/osm.xml'
renderd[5981]: An error occurred while loading the map layer 'default': Failed to parse expression: "name" in style 'area-text' in TextSymbolizer at line 258 of '/root/src/mapnik-style/osm.xml'
renderd[5981]: An error occurred while loading the map layer 'default': Failed to parse expression: "name" in style 'area-text' in TextSymbolizer at line 258 of '/root/src/mapnik-style/osm.xml'
renderd[5981]: An error occurred while loading the map layer 'default': Failed to parse expression: "name" in style 'area-text' in TextSymbolizer at line 258 of '/root/src/mapnik-style/osm.xml'

-----------

what's the problem? please help me! thx!

---
Reply to this email directly or view it on GitHub:
https://github.com/openstreetmap/mod_tile/issues/9
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.org/pipermail/tile-serving/attachments/20130408/a61eaec4/attachment-0001.html>


More information about the Tile-serving mailing list