[Tile-serving] [osm2pgsql] Update CREATE EXTENSION information (#24)

pnorman notifications at github.com
Mon May 13 08:27:13 UTC 2013


Yes, but the matrix for install methods with different postgres+postgis versions isn't the simplest.

With postgis 1.5 it's a .sql file, path depending on postgresql version
with postgresql >= 9.1 and postgis >= 2.0 it's CREATE EXTENSION.

I'm not sure if postgresql 8.4 and postgis 2.0 works.

On ubuntu 12.10 the easiest combination to install is 9.1+1.5 and that's what the switch2osm package guide uses.

Frederik's presentation shows 9.1+2.0 is about 20% faster than 8.4+1.5 and 2.0 is reportedly much better at avoiding corrupt geometries and crashes. For these reasons I'd consider 9.1 and 2.0 the minimum recommended versions. On the other hand, 9.1 and 1.5 is **so** much easier to set up.

So those are two reasonable "default" options, 9.1+1.5 and 9.1+2.0, one easier to install on ubuntu, and one superior in every other way and not relying on software less than a year old. 9.1+1.5 is probably the reasonable one to document, but it does suck not having 2.0 in repos.

fwiw, I'll be going for 9.2+2.0 (or later) when I next reinstall, but one incidental advantage of ``CREATE EXTENSION`` is that it is no longer version specific.

One of the reasons I'll likely be switching from ubuntu is the difficulty of installing these mixes of binary packages and from source

---
Reply to this email directly or view it on GitHub:
https://github.com/openstreetmap/osm2pgsql/pull/24#issuecomment-17798365
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.org/pipermail/tile-serving/attachments/20130513/cdb0bee5/attachment-0001.html>


More information about the Tile-serving mailing list