[OSM-dev] Succeeded in setting up a testserver

Immanuel Scholz immanuel.scholz at gmx.de
Sat Jul 22 00:33:34 BST 2006


Hi,

> > I succeeded in setting up a testserver. So ask me if you run into
> > problems ;)
> > 
> 
> And you did not get this path problem?
> 
> I still get:
> 
> [Fri Jul 21 22:02:10 2006] [error] mod_ruby: failed to require /home/tompe/osm/s
> vn/www.openstreetmap.org/ruby/api/apache/simple-auth
> [Fri Jul 21 22:02:10 2006] [error] mod_ruby: error in ruby
> [Fri Jul 21 22:02:10 2006] [error] mod_ruby: /home/tompe/osm/svn/www.openstreetm
> ap.org/ruby/api/osm/osmlog.rb:3:in `load': no such file to load -- servinfo.rb (
> LoadError)
> [Fri Jul 21 22:02:10 2006] [error] mod_ruby:   from /home/tompe/osm/svn/www.open
> streetmap.org/ruby/api/osm/osmlog.rb:3
> [Fri Jul 21 22:02:10 2006] [error] mod_ruby:   from /home/tompe/osm/svn/www.open
> streetmap.org/ruby/api/osm/dao.rb:7

What's your RubyAddPath - setting in the apache config? should be
something like:

RubyAddPath /home/tompe/osm/svn/www.openstreetmap.org/ruby/osm
RubyAddPath /home/tompe/osm/svn/www.openstreetmap.org/ruby/api/apache
RubyAddPath /home/tompe/osm/svn/www.openstreetmap.org/ruby/api/0.3
RubyAddPath /home/tompe/osm/svn/www.openstreetmap.org/ruby/api



> The photo thing worked but I tried to save and save "All filed" and I
> thought all layers (photos, gpx track and map data) would be saved.
> Since there is some work to synchronize the photo I would lika to save
> the setup.  Is this possible?

In theory, you should have to synchronize your gps unit only once (or
resync it after some time in the unlikely case that its clock drifts too
fast).

If the sync is ok, then you should be able to load the pictures right
away.

If you point me to a small and free java library which can write EXIF
data into JPG's, I will implement the saving of the GPS coordinates into
JOSM, so the syncing with the GPS track would become much easier.. ;)

Ciao, Imi.





More information about the dev mailing list