[OSM-dev] Problems with Tiles at Home under Windows

Dirk-Lüder Kreie osm-list at deelkar.net
Sat Apr 21 19:26:36 BST 2007


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hansen schrieb:
> Hi,
> 
> today, I installed ActivePerl 6 with 7-Zip and Inkscape under Windows XP. Now, I want to render some tiles for tiles at home. So, I copied the svn to my local disk and started the tilesGen.pl script with the Windows command line. The tilesGen script starts, but after 1 second it stops with the following failure:
> 
> C:\tiles at home>perl tilesGen.pl
> - Using working directory c:\temp\
> - Inkscape version 0.45.1
> - xmlstarlet version 1.0.1
> 'zip' is not recognized as an internal or external command,
> operable program or batch file.
> Can't find zup <using "zip">
> 
> C:\tiles at home>
> 
> How can I solve this "zip" problem? I only installed 7-Zip...
> I have many Windows machines here and I think they will be great for tiles at home! :-)

You might want to configure "Zip" in the tilesAtHome.conf to point to
your 7-zip command line executable.  (not sure if that exists and you'd
still have to test if it works the same way as "zip")
so that should read
Zip=C:\program files\7-zip\7z.exe # or something like that.

Please give feedback about this, we have too few windows testers, and
update the wiki-page of tiles at home with any useful stuff you might want
to share with other windows users.

- --

Dirk-Lüder "Deelkar" Kreie
Bremen - 53.0953°N 8.8651°E

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFGKldcFUbODdpRVDwRAimDAJ0aRvSMKVTf0NM4vPy3UTddmZwUhQCgxs0U
1293aAo4QeKD29ivEfewjRM=
=qqFT
-----END PGP SIGNATURE-----




More information about the dev mailing list