[OSM-dev] [RAILS] installing on Ubuntu Edgy?

Schuyler Erle schuyler at nocat.net
Sat Apr 28 07:27:09 BST 2007

To better inform my understanding of OSM's data modelling issues, and
answer the general call for people to try it for themselves at home, I
got the Rails port of the OSM service from SVN and tried installing
it. Unfortunately, knowing nothing about Rails, I ran into a few

First off I had to install Rails via gems in order to stop errors
about missing rubygems:

Next, I got errors about "undefined method `compress_output'".ran:
  $ ruby script/plugin discover
  $ ruby script/plugin install output_compression

This yielded a "undefined method `request_for_component' for module
`ActionController::Components'". So then I followed the instructions
However... this still yields an error on /api/0.4/map?bbox=... of
"undefined method `compress_output'" again.

At this point I went and commented out all the "after_filter
:compress_output" lines, which yielded this error:

 NoMethodError in ApiController#map
 undefined method `xmlschema' for nil:NilClass

And a stack trace:

 app/models/segment.rb:84:in `to_xml_node'
 app/controllers/api_controller.rb:88:in `map'
 app/controllers/api_controller.rb:87:in `map'

I am afraid I already reveal the depths of my ignorance with Rails.
Any advice for getting Rails working on Ubuntu or Debian would be most


More information about the dev mailing list