[OSM-dev] osm2pgsql libgeos requirements

Keith Sharp kms at passback.co.uk
Fri Mar 16 12:20:54 GMT 2007


Hello,

I've noticed that the latest version of osm2pgsql requires libgeos
version 3.0.  Unfortunately this version is not yet available
pre-packaged for Fedora Core 6.

Could I suggest that the two occurrences of "#if 1" in
build_geometry.cpp are changed to "#ifndef GEOS_TWO" (lines 24 and 45).
This will allow me build using:

	CXXFLAGS="-DGEOS_TWO" make

everyone else should be able to build as before.

Thanks,

Keith.





More information about the dev mailing list