[OSM-dev] Importing planet.osm into api0.5 db?

Ted Mielczarek ted.mielczarek at gmail.com
Mon Oct 1 17:32:59 BST 2007


On 10/1/07, Frederik Ramm <frederik at remote.org> wrote:
> I must admit that I never did this myself ;-)
>
> Osmosis should do it and it would be great if you could test it, the
> schema error message is surely just a minor glitch.

If I pass "validateSchemaVersion=no" to osmosis, it fails with an exception:

Exception in thread "Thread-1-read-xml-0.5"
com.bretth.osmosis.core.OsmosisRuntimeException: Unable to set a
prepared statement parameter for a node.
        at com.bretth.osmosis.core.mysql.v0_5.MysqlWriter.populateNodeParameters
(MysqlWriter.java:384)

I guess this doesn't work.  :)

Regards,
-Ted




More information about the dev mailing list