[OSM-dev] extract_polygon_0.5.pl bugs

Nick Burch openstreetmap at gagravarr.org
Wed Oct 10 13:48:32 BST 2007


On Tue, 9 Oct 2007, Sascha Silbe wrote:
>>> Will try planetosm-excerpt-area.pl now.
>> I think that one hasn't been made 0.5 compliant but you can of course
>> do that if you prefer.
> The version currently in SVN has some bits about relations, so I guess 
> it has already been done. Haven't tested it yet, though, since it needs 
> special OSM perl modules installed.

You shouldn't need any special perl modules, beyond those in a normal svn 
checkout. It should even just pick them up based on your current path, 
since it knows how much further up the perl library directory normally is 
in a checkout.

Oh, and the script ought to work fine with 0.5, as should the related 
planetosm-excerpt-tags.pl script (they have both been updated)

Nick




More information about the dev mailing list