[OSM-dev] Building quadtile-capable rails_port on OS X

Richard Fairhurst richard at systemeD.net
Fri Sep 28 18:36:35 BST 2007


I'm trying to update my local install to the latest version, which of  
course includes quadtiles - and this requires a function library to  
be installed for MySQL.

Has anyone successfully achieved this under OS X?

I can build the library after tweaking the makefile a little  
(rename .so to .dylib, replace -shared with -dynamiclib). But MySQL  
steadfastly refuses to find the file:

   mysql> create function tile_for_point returns integer soname
   'libquadtile.dylib';

   ERROR 1126 (HY000): Can't open shared library 'libquadtile.dylib'
   (errno: 9 dlopen(libquadtile.dylib, 2): image not found)

I've tried it under 4.x, with a symlink from /usr/local/mysql/lib  
and /usr/local/lib: I've tried it under 5.1, specifying the  
plugin_dir as /usr/local/mysql/lib and putting it there; no joy at all.

Alternatively, is there any way an "easy-but-slow" workaround could  
be provided avoiding the need to install the function when running  
locally?

Needless to say, not being able to develop Potlatch any more is a bit  
of a problem for me, and might become a bit of a problem for others  
in a week's time when API 0.5 obsoletes the current version. :|

cheers
Richard




More information about the dev mailing list