[OSM-dev] Mapnik dist-upgrade broke my rendering

Frederik Ramm frederik at remote.org
Sat Apr 12 23:23:07 BST 2008


Hi,

> That looks like what I got prior to Tom's fix. Are you sure you are
> running the latest SVN version of Mapnik?

I thought I was. But it seems that the latest checkout changed the
SConstruct file so that it was looking for postgresql headers in
/usr/include, not /usr/include/postgresql where they are on my
(Ubuntu) box. Because they are not required, the new build simply ran
without re-creating the postgis input plugin. Since I had not deleted
/usr/local/lib, the old version still sat there...

Changing the SConstruct file fixed all my troubles, a new postgis
plugin is generated, and everything works like a charm.

Thanks again! (Also to Tom who fixed the thing in the first place.)

Bye
Frederik

-- 
Frederik Ramm  ##  eMail frederik at remote.org  ##  N49°00'09" E008°23'33"





More information about the dev mailing list