[OSM-dev] osm2pgsql not importing route=subway

Roeland Douma unix at rullzer.com
Tue Aug 26 16:02:37 BST 2008


Hi,

I noticed that when I'm running osm2pgsql it does not import route=subway. 
While other routes are added (like bus, ferry, hiking etc). I am using an 
extract from hypercube ( 
http://hypercube.telascience.org/planet/planet-nl-latest.osm.gz ).

The relations are present in the file:

example:
  <relation id="18423" timestamp="2008-06-26T07:57:25Z" user="rullzer">
    <member type="way" ref="22375740" role=""/>
    <member type="way" ref="22375742" role=""/>
    <member type="way" ref="23158053" role=""/>
    <member type="way" ref="23158054" role=""/>
    <member type="way" ref="23208046" role=""/>
    <member type="way" ref="23208061" role=""/>
    <member type="way" ref="23208093" role=""/>
    <member type="way" ref="23208094" role=""/>
    <member type="way" ref="24342559" role=""/>
    <member type="way" ref="24342562" role=""/>
    <member type="way" ref="25013423" role=""/>
    <member type="way" ref="25029041" role=""/>
    <member type="way" ref="25029042" role=""/>
    <member type="way" ref="25097896" role=""/>
    <member type="way" ref="25097897" role=""/>
    <tag k="route" v="subway"/>
    <tag k="operator" v="GVB"/>
    <tag k="type" v="route"/>
    <tag k="ref" v="54"/>
  </relation>

I'm running the latest osm2pgsql from svn.

Anybody has any idea why the route=subway is not added while the others are? 
Or more important how I can solve it?

Thanks in advance,
Roeland Douma




More information about the dev mailing list