[OSM-dev] Osmosis Output Error

Brett Henderson brett at bretth.com
Tue Dec 9 22:27:23 GMT 2008


Karl Newman wrote:
> On Tue, Dec 9, 2008 at 2:03 PM, Andrew Ayre <andy at britishideas.com 
> <mailto:andy at britishideas.com>> wrote:
>
>     Brett Henderson wrote:
>     > Karl Newman wrote:
>     >> I just noticed that Brett checked in some changes to the
>     DataPostbox
>     >> today. Can you try with an earlier version (say r12258, just before
>     >> the change) to see if it works? I'm sure Brett would like to
>     know if
>     >> something is broken.
>     > Ouch.  Sorry about that.  I'll take a look this evening.  Karl (or
>     > anybody else familiar with osmosis), feel free to back out my
>     change if
>     > you have time.  The changes should be isolated to that class.
>     >
>     > Brett
>
>     I'll give a previous rev a try, but I wanted to first mention that
>     I get
>     the same error with an older version I was using (downloaded a
>     couple of
>     months ago).
>     I can make the osm files available if it helps.
>
>     Thanks!
>
>     Andy
>
>
> So, sounds like the most recent changes are not the issue. Do you know 
> if SRTM2OSM creates entities with negative ids? If not, you may run 
> into collisions with the other data file that you're trying to merge.
>
> Karl
Andrew, it would be great if you could put your files online somewhere.  
I'll take a look this evening if Karl doesn't beat me to it.

My biggest concern at this point is that you don't appear to be getting 
a decent error message.  Perhaps I'm losing an exception stack trace 
somewhere.  It makes it hard to diagnose the problem.

Brett






More information about the dev mailing list