[OSM-dev] [Merkaartor] Crowd Sourced Testing of OSM 0.6 API

Chris Browet cbro at semperpax.com
Fri Dec 12 15:35:32 GMT 2008


Actually, the problem is that I get zero-sized replies (the 502 is sent by
my proxy).

I guess some have already succeeded in uploading, right? With Merkaartor?
(In case it is a local config error)

- Chris -

On Thu, Dec 11, 2008 at 4:27 PM, Shaun McDonald
<Shaun at shaunmcdonald.me.uk>wrote:

> According to the server log, it appears to be a 401 Unauthorized that is
> being returned.
> Could it be that the auth headers aren't being sent properly?
>
> shaun
>
> On 11 Dec 2008, at 14:54, Chris Browet wrote:
>
> Not too sure if it's Merkaartor or the API (because 0.6 in Merkaartor was
> coded by Bart back in June).
>
> I receive a "502 - Bad Gateway" when trying to create a changeset, in a
> blank area if that matter.
> I checked the api page and the request seemed fine to me.
>
> - Chris -
>
> On Thu, Dec 11, 2008 at 12:22 PM, Shaun McDonald <
> Shaun at shaunmcdonald.me.uk> wrote:
>
>> Hi,
>>
>> As the 0.6 XML API is now feature complete, I'd like to start a push for
>> getting it tested, to iron on the final bugs prior to going live.
>>
>> Can you all please take a look at the following page to find out more
>> about testing the 0.6 API:
>>
>> http://wiki.openstreetmap.org/wiki/OSM_Protocol_Version_0.6/Crowd_sourced_Testing
>> And then please put your testing hats on to find the bugs.
>>
>> Shaun
>>
>> _______________________________________________
>> Merkaartor mailing list
>> Merkaartor at openstreetmap.org
>> http://lists.openstreetmap.org/listinfo/merkaartor
>>
>>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.org/pipermail/dev/attachments/20081212/aff004cc/attachment.html>


More information about the dev mailing list