[OSM-dev] [Merkaartor] Crowd Sourced Testing of OSM 0.6 API

Thomas Wood grand.edgemaster at gmail.com
Sun Dec 14 01:59:47 GMT 2008


2008/12/13 Shaun McDonald <Shaun at shaunmcdonald.me.uk>:
>
> On 13 Dec 2008, at 10:21, Tom Hughes wrote:
>
>> Chris Browet wrote:
>>
>>> Tom, I think Merkaartor must be doing something wrong vs. the http
>>> server you are using on the api06.dev server.
>>>
>>> Curl-ing the request to the server is ok, apparently Shaun's local
>>> is ok
>>> but I cannot get anything else than zero-sized to the api06 server
>>> from
>>> Merkaartor when PUT-ting.
>>>
>>> Would you be able to check the logs of the http server to check for
>>> relevant messages?
>>
>> The test server is nothing to do with me.
>>
>
> The test server was setup by Thomas Wood (Edgemaster) and I also have
> read access to it.
>
> I've noticed that there is a changeset created by Merkaartor.
> http://api06.dev.openstreetmap.org/browse/changeset/31 and
> http://api06.dev.openstreetmap.org/browse/changeset/30
>
> Therefore it seems that it can be done.
>
> It looks like it may be an issue with the way that passenger or Apache
> is dealing with the requests, which isn't showing up in any it the
> other editors or application servers. (When I'm running locally with
> webrick, I see now issue).
>
> Shaun

This seems to be some sort of apache/passenger issue, looking through
logs for one changeset create request:
rails:
[2008-12-14 01:51:26.887703 #23473] Processing
ChangesetController#create (for 77.103.210.112 at 2008-12-14 01:51:26)
[PUT]
[2008-12-14 01:51:26.887831 #23473]   Parameters: {"action"=>"create",
"controller"=>"changeset"}
[2008-12-14 01:51:26.888296 #23473] Filter chain halted as
[:authorize] rendered_or_redirected.
[2008-12-14 01:51:26.888468 #23473] Completed in 0.00041 (2427
reqs/sec) | Rendering: 0.00017 (42%) | DB: 0.00000 (0%) | 401
Unauthorized [http://api06.dev.openstreetmap.org/api/0.6/changeset/create]

Apache access.log:
77.103.210.112 - - [14/Dec/2008:01:51:26 +0000] "PUT
/api/0.6/changeset/create HTTP/1.1" 401 - "-" "-"

Apache error.log:
[Sun Dec 14 01:51:26 2008] [error] [client 77.103.210.112]
(104)Connection reset by peer: ap_content_length_filter:
apr_bucket_read() failed

And finally a Wireshark session is reporting the request but no
response from the server.

I've googled it a little, but nothing useful turned up.

I'll try a Passenger recompilation soon to see if anything odd
happened in the upgrade, else I'll roll back to the 2.0.3 version
which I seem to recall worked fine with Merkaartor.

-- 
Regards,
Thomas Wood
(Edgemaster)




More information about the dev mailing list