[OSM-dev] [OSM-talk] Error while uploading with JOSM

David Earl david at frankieandshadow.com
Fri Feb 8 10:59:26 GMT 2008


On 08/02/2008 00:38, Frederik Ramm wrote:
> Hi,
> 
>> The feature of the API REST interface is lots of rapid, small 
>> independent requests, which would be pretty unusual for most people.
> 
> We might be able to do keep-alive.

Isn't that done automatically anyway?

BUT, there appears to be a server setting for lighttpd 
'max-keep-alive-requests' (default 128 - what is it on ours?) after 
which the connection is dropped.

This would fit with the point at which my upload ALWAYS gets interrupted.

I tried it again this morning doing a null change for about 2,500 
elements. It didn't lock me out permanently this time (so maybe that was 
a different problem), but it did consistently drop the connection after 
what looked like about 250 elements (if our server is set to 256 that 
would be more of a smoking gun).

We could solve that with a retry in JOSM (was that already done - I 
haven't updated by JOSM in a couple of weeks?). (Though I got a later 
'precondition failed' - is this related? I deleted a way which didn't 
get deleted on the server - because of the timeout? Does a request get 
lost when it times out? Am I therefore losing data?)

But that's not really the same as I was seeing yesterday and the two 
previous occasions (though if I didn't lose the connection, I might not 
be getting into this situation).

I tried again and I *did* get locked out the second time, but only for 
about 10 minutes this time (was 25 last night). Slightly surprisingly 
during this time I *could* get access from another machine on my 
intranet, so it must be either something on my PC or something in the 
router that knows about my machine specifically, and *not* my ISP or the 
server. There's nothing I can look at (log etc) or set in my router that 
would affect this (it's a Belkin Wireless G Plus MIMO, FWIW). It doesn't 
appear to be Windows Firewall, or Windows Defender and I'm not running 
anything else that would be intercepting traffic AFAIK. I'm stumped.

BTW, I can't successfully ping www.openstreetmap.org at all at any time 
or from any network I have access to.

David





More information about the dev mailing list