[OSM-dev] Osmosis DB schemas?

Tom Enterline (OSM) osm at enterline.us
Fri Feb 15 02:12:53 GMT 2008


Hi,

I'm creating a development environment for the first time, following the 
instructions on The_Rails_Port wiki page, and have created the database. 
I'm running in problems loading data into the DB.

I downloaded one US State (Pennsylvania) from planet.king-nerd.com, and 
downloaded the latest Osmosis. When I tried to load the osm file using 
Osmosis, I got an error

Exception in thread "Thread-1-read-xml" 
com.bretth.osmosis.core.OsmosisRuntimeException: The database schema 
version of 10 does not match the expected version of 8.

Thinking the problem was the database version in the "rake db:migrate 
VERSION=10" step, which has a FIXME attached, I recreated the database, 
and tried it without the VERSION=10, i.e. just "rake db:migrate"

Now I get
Exception in thread "Thread-1-read-xml" 
com.bretth.osmosis.core.OsmosisRuntimeException: The database schema 
version of 14 does not match the expected version of 8.

I see that Osmosis has an option to turn off schema verification, but 
that seems dangerous.

Is the mismatch between the DB and the osm file I downloaded, or is it 
between Osmosis and the file and/or database?

What do I do to get the schemas to match?

Thanks,
Tom




More information about the dev mailing list