[OSM-dev] Osmosis broken

Tom Hughes tom at compton.nu
Sun Feb 24 17:44:10 GMT 2008


In message <52ae42fa0802240831i1b2ac661jcc3598bd0f30e093 at mail.gmail.com>
          "Karl Newman" <siliconfiend at gmail.com> wrote:

> On Sun, Feb 24, 2008 at 5:18 AM, Tom Hughes <tom at compton.nu> wrote:
> 
> > That'll be when I updated the database to schema version 11 for Steve's
> > changes. Unfortunately that breaks Osmosis... I think Brett's away at the
> > moment, so this might not be very easy to fix.
> 
> Actually, I think it's not too bad to fix. I don't think Osmosis cares about
> user preferences (assuming that was the major change), so all you have to do
> is bump the expected schema version to 11. It's in
> Osmosis/src/com/bretth/osmosis/core/mysql/v0_5/MySqlVersionConstants.java Of
> course, then you'd have to recompile and deploy the new version.

The problem is not changing the code, it's that I have no idea how
to go about building it or deploying the fixed version on dev.

> Alternately, you could temporarily modify the command line to add the option
> validateSchemaVersion=no to the database read task. It might be nice to be
> able to override the expected schema version with a command line argument,
> but that's not in there right now.

That sounds a bit easier...

Tom

-- 
Tom Hughes (tom at compton.nu)
http://www.compton.nu/




More information about the dev mailing list