[OSM-dev] 0.6 api - one more time

Martijn van Oosterhout kleptog at gmail.com
Mon May 5 18:05:01 BST 2008


2008/5/5 80n <80n80n at gmail.com>:
> Unless someone thinks that 2,000 (guesstimate) JOSM users will all upgrade
> simultaneously, then it would be unwise to just switch from 0.5 to 0.6
> overnight.

If it were up to me I'd suggest that the API starts returning versions
numbers *now* (where possible, nodes don't have them yet). And we
deploy in the near future the changes to JOSM to use them and return
them.

The way I wrote the JOSM patch was essentially so that you could
deploy a version of JOSM beforehand that only needed a preference
change to make it work for 0.6. With this in place by the time we
actually upgrade the server most people will already be running up to
date versions.

In other words, I think it's easier to get clients to support both
versions, than it is to get the server to support both.

Have a nice day,
-- 
Martijn van Oosterhout <kleptog at gmail.com> http://svana.org/kleptog/




More information about the dev mailing list