[OSM-dev] 0.6 api - one more time

SteveC steve at asklater.com
Tue May 6 10:39:37 BST 2008


On 6 May 2008, at 10:33, Richard Fairhurst wrote:

> SteveC wrote:
>
>> I disagree, publicise widely and just switch. It's worked every time
>> in the past. It's not _entirely_ clear that it's possible to run  
>> both,
>> and in the past it certainly hasn't been such as the dropping of
>> segments.
>>
>> The only think I have a problem with is backward supporting the crap
>> in potlatch.
>
> No-one has ever needed to add "backward supporting" code for Potlatch
> anywhere, whether on 0.4 or 0.5, and there's no question of them doing
> so this time, either. You may not like the internals and I can
> understand that, but Potlatch always tries to play nice. With 0.6, as
> with 0.5, the main API is actually moving slightly closer to the way
> Potlatch has always done things _anyway_.

well thats the point, you're going to reimplement everything in an  
unmaintainable way in the RichardAPI

unless I can stop you

> Ah, the bullets you have to take for being ahead of the curve. :p
>
> But to be a bit more helpful:
>
>> is there anything else that should be put in 0.6? Probably a good
>> idea to talk about it now.
>
> Well, ideally it'd be good to add
>
> PUT /api/0.6/way/123456/full
> to do the same thing as Potlatch's 'putway' call, and then migrate the
> latter to use the same methods.

oh I thought I did that

Best

Steve





More information about the dev mailing list